Technology Toolbox

Your technology Sherpa for the Microsoft platform

Jeremy Jameson - Founder and Principal

Search

Search

Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

Note
This post originally appeared on my MSDN blog:

Since I no longer work for Microsoft, I have copied it here in case that blog ever goes away.

I've mentioned in the past how I run a Windows Server 2003 mail server in order to use the POP3 service for basic e-mail functionality, and that I didn't have any interest in finding an alternative when I discovered POP3 is no longer available in Windows Server 2008. Well, I guess I need to start investing the effort in finding a new email service to run for demo purposes after all.

After installing Office 2010 recently on my home desktop, I discovered that Outlook 2010 apparently considers the simple implementation of the POP3 protocol in Windows Server 2003 to be obsolete, because after upgrading from Outlook 2007, I can no longer connect to my mail server (BANSHEE) and receive email messages.

At first, I suspected the problem might somehow be caused by installing the new version of the Microsoft Outlook Hotmail Connector (which, for Outlook 2010, is currently still a beta version), but I verified that the problem still exists even after uninstalling it.

I also tried disabling the Require Secure Password Authentication (SPA) for all client connections option for the POP3 service, but I couldn't get it to connect even when sending my username and password in clear text over the wire (which obviously isn't a good idea anyway, so I suppose I should be glad that option didn't work).

Here's a network trace (when SPA is enabled) from my primary desktop (WOLVERINE) with Outlook 2010 installed:

449   3.055000   BANSHEE    WOLVERINE  POP3   POP3:Response: +OK: Microsoft Windows POP3 Service Version 1.0 <846424703@banshee.corp.technologytoolbox.com> ready.
450   3.055000   WOLVERINE  BANSHEE    POP3   POP3:Command: CAPA 
451   3.056000   BANSHEE    WOLVERINE  POP3   POP3:Response: -ERR, Error: Unacceptable command
452   3.056000   WOLVERINE  BANSHEE    POP3   POP3:Command: QUIT

Like I said, it seems that Outlook 2010 doesn't like the simple implementation of the POP3 protocol in Windows Server 2003. Specifically, if the POP3 server doesn't understand the CAPA command (to list the capabilities supported by the mail server), then Outlook 2010 doesn't even bother trying to authenticate (at least not with SPA).

Here is a similar network trace from one of my VMs (FOOBAR2) that still has Outlook 2007 installed:

2225   15.118164   BANSHEE   FOOBAR2   POP3   POP3:Response: +OK: Microsoft Windows POP3 Service Version 1.0 <846956359@banshee.corp.technologytoolbox.com> ready.
2229   15.210937   FOOBAR2   BANSHEE   POP3   POP3:Command: AUTH  
2230   15.212890   BANSHEE   FOOBAR2   POP3   POP3:Response: +OK
2231   15.241211   FOOBAR2   BANSHEE   POP3   POP3:Command: AUTH  NTLM
2232   15.243164   BANSHEE   FOOBAR2   POP3   POP3:Response: +OK
2234   15.243164   FOOBAR2   BANSHEE   NLMP   NLMP:NTLM NEGOTIATE MESSAGE
2235   15.245117   BANSHEE   FOOBAR2   NLMP   NLMP:NTLM CHALLENGE MESSAGE
2236   15.245117   FOOBAR2   BANSHEE   NLMP   NLMP:NTLM AUTHENTICATE MESSAGE, Domain: TECHTOOLBOX, User: jjameson, Workstation: FOOBAR2
2239   15.335937   BANSHEE   FOOBAR2   POP3   POP3:Response: +OK: User successfully logged on
2240   15.336914   FOOBAR2   BANSHEE   POP3   POP3:Command: STAT 
2241   15.336914   BANSHEE   FOOBAR2   POP3   POP3:Response: +OK: 1 827
2242   15.337890   FOOBAR2   BANSHEE   POP3   POP3:Command: UIDL 
2243   15.337890   BANSHEE   FOOBAR2   POP3   POP3:Response: +OK: 1 messages (827 octets)
2244   15.337890   FOOBAR2   BANSHEE   POP3   POP3:Command: LIST 
2245   15.338867   BANSHEE   FOOBAR2   POP3   POP3:Response: +OK: 1 messages (827 octets)
2262   15.383789   FOOBAR2   BANSHEE   POP3   POP3:Command: RETR  1
2263   15.384765   BANSHEE   FOOBAR2   POP3   POP3:Response: +OK: 827 octects
2374   15.774414   FOOBAR2   BANSHEE   POP3   POP3:Command: DELE  1
2375   15.775390   BANSHEE   FOOBAR2   POP3   POP3:Response: +OK: Message marked as deleted
2433   15.819336   FOOBAR2   BANSHEE   POP3   POP3:Command: QUIT

I suspect the problem with Outlook 2010 might be due to the fact that I'm not using SSL to connect to my POP3 service. However, unless I'm missing something obvious, I don't believe it's even possible to configure SSL on the POP3 service in Windows Server 2003. Sure, I could change the port number from the default 110 to 995, but how would I assign the certficate?

I suppose this means I'll have to start looking at third-party email servers for demo purposes and learning about various mail-enabled features in other products and technologies, such as SharePoint. I really need something much more "lightweight" than Exchange to address my specific scenarios.

The POP3 service in Windows Server 2003 was great for demo and training purposes -- while it lasted. I suppose another option is to simply use a different e-mail client instead of Outlook 2010, but I'm sure you can imagine why that option doesn't sound very appealing.

Update (2010-04-27)
I started investigating alternate e-mail services this morning, but quickly discovered there are a lot of potential candidates out there. One of the simplest options looked promising at first, but after reading through the multitude of comments describing various issues with it, I discovered that it doesn't appear to work with Outlook 2010 either.

This morning, I decided to just "bite the bullet" and download Mozilla Thunderbird to see if I could use this to connect to my Windows Server 2003 POP3 service for demo and training purposes. It took less than 10 minutes to download, install, and configure my e-mail account. Note that Thunderbird automatically detected the DNS names of my POP3 and SMTP servers (which are really one and the same) just by typing in my e-mail address. The only "tricky" part was ensuring that I checked the option to Use secure authentication (since my POP3 service is configured to require SPA).

I really don't like the idea of not using Outlook for demos, but unless someone can point me to a POP3 service that is free, lightweight (i.e. can run adequately in a VM with a mere 256MB of memory), and trivial to install and configure, then I'm going to stick with the Windows Server 2003 POP3 service for now.

Comments

  1. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    May 12, 2010 4:25 PM
    Syed Qutubuddin

    Hi,

    So the moral of the story is that we don't have a solution to pull our email from exchange using POP as of now. May we will get a solution soon on this.

    Regards

    Qutub

  2. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    May 26, 2010 3:21 AM
    Jeremy Jameson
    Gravatar

    @Syed, I'm not aware of any solution using Outlook 2010 in this scenario. However, there are other e-mail clients that you can use instead.

    I mentioned before in my update that I confirmed Thunderbird works.

    Somebody also e-mailed me and indicated that Windows Live Mail works as well.

    Honestly, I wouldn't expect the Office team to release a patch for this. I believe they deliberately pulled the NTLM authentication feature for Exchange (which consequently also affected the Windows Server 2003 POP service), and I just don't see there being a big enough demand for this to bring the feature back in a QFE or Service Pack. But, hey, that doesn't mean we can't hope for a fix ;-)

  3. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    June 8, 2010 12:00 AM
    sylvia

    We upgraded from explorer7 to 8 and seems to have lost our pop3 and smlt servers? we use email from charter internet service. How can I download these missing servers? I'm getting no where on my own. When we use to go to tools and then account to see what servers we have and to see the setup; that is all gone...explorer 8 dropped it or deleted it. this is very frustrating. I wonder if I should go back to explorer 7?

  4. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    June 8, 2010 12:01 AM
    sylvia

    We upgraded from explorer7 to 8 and seems to have lost our pop3 and smlt servers? we use email from charter internet service. How can I download these missing servers? I'm getting no where on my own. When we use to go to tools and then account to see what servers we have and to see the setup; that is all gone...explorer 8 dropped it or deleted it. this is very frustrating. I wonder if I should go back to explorer 7?

  5. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    June 21, 2010 9:37 PM
    Fred

    Any progress on this?  I am having a problem that may be related.  It fails at the CAPA negotiation like your problem does.  Basically just Outlook talking to a Plesk email server using POP3.  Outlook 2007 just worked.  I upgraded to Outlook 2010 and never touched a thing and it no longer works.  Only way I can get it to work is by enabling SSL which I never had to do in Outlook 2007.  Again, this is without changing ANYTHING on the Server or the client computer other than the version of Outlook.  Funny thing is I upgraded Outlook on another pc on another network and it does not have this problem.  It can connect to the same email server without SSL enabled.  This one has really got me scratching my head.

  6. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    June 24, 2010 1:07 AM
    Fred

    Ok, fixed my problem.  In my case my Cisco 871 router had POP3 protocol inspection enabled.  It does not recognize the 'CAPA' command sent by Windows so it was dropping the packet.  So as far as I can tell, Outlook 2003, 2007, Outlook Express, Windows Live Mail, and probably every other email client out there this does not have any effect.  They either don't send the 'CAPA' command or just ignore the error.  Outlook 2010 does NOT ignore the error and basically gives up at that point.

    So this may be related to the problem the author is having.  My guess is Outlook 2010 should be fixed and made the same as every other email client out there including previous version of Outlook.

  7. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    September 24, 2010 12:38 PM
    Alan

    I have just loaded Outlook 2010 and am encountering the same issue with a backend hMailServer implementation.  I have multiple Outlooks running as clients on other machines, just Outlook 2010 appears to have an issue.

  8. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    October 4, 2010 1:54 AM
    Sailen

    Thanks for the lead.. Fixed My Problem..  We have Cisco 857W and it was the CAPA problem.  It stopped mail to Outlook2010 and iOS (iPad, iPhone)..  All works now.

    Commands issued to router :

    enable (This will prompt for the enable password)

    config t

    no ip inspect name SDM_MEDIUM pop3 reset

  9. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    November 21, 2010 5:45 PM
    Digital Doug

    Disable SPA on the Windows 2003 POP3 server and do the same in Outlook 2010 POP setup..

    Now you can connect if the username is the full email address, "doug@test.com" instead of just doug (if using the Secure Password Authentication).

  10. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    January 6, 2011 8:28 PM
    WebAL

    Thank you Digital Doug,

    This solved it!

    Regards,

    WebAL

  11. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    February 24, 2011 6:31 PM
    taz_man

    Thank you for your tips regarding the Cisco inspection. It works for me

  12. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    April 7, 2011 6:52 PM
    Letizia79

    Hello to everyone!

    I have the same problem: Outlook 2010 fails login to POP3/SMTP services on Server 2003.

    Furthermore, the solution proposed by Digital Doug does not work: on my Windows 2003 POP3 service SPA is disabled, and my username is "MyName@MyDomain.com"... though, I can no longer connect to my mail server!  

    Any suggestion????

  13. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    April 13, 2011 5:06 PM
    Letizia79

    I found the solution!

    As often happens, the best thing is to discard Microsoft products:

    1. Download hMailServer

    http://www.hmailserver.com

    2. Install and configure hMailServer (following the detailed instructions provided)

    3. Disable (STOP or DELETE) the POP3 and SMTP Service on Windows Server 2003

    4. Configure your email Clients (including MS Outlook 2010!) with your new hMailServer POP3/SMTP service parameters

    ...and here's all email Clients perfectly working!!!

    So, using hMailServer, you can continue to use your MS Outlook 2010 Client (that you bought - giving money to Microsoft!) and you do not have to replace your Windows 2003 Server (moreover, please note POP3 is no longer available in Windows Server 2008, so you should buy MS Exhange License!).

    ...Hope this will help anybody who has met or will meet this bad situation!

  14. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    May 2, 2011 7:27 PM
    Bill48105

    FYI: Odds are you would need to use hMailServer 5.4 (currently alpha but stable) since versions prior to that gave similar '-ERR' response to CAPA command which I'd assume could trip up Outlook 2010 too.

    (I have quite a few Outloook 2010 users on hmailserver 5.4 & they all work fine but have not tested them with older versions of hmailserver.. Not sure what Letzia79 used as version was not mentioned.)  

    Link to 5.4 is available in hmailserver forums or I'll save you a little effort:

    www.hmailserver.com

    Bill

  15. # re: Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    August 23, 2011 8:09 PM
    Aurelien

    Hello,

    I had the same problem with a pop3 service from windows 2003 server.

    Old Outlook versions work without any problem. With Outlook 2010, the same account settings didn't work.

    After  reading all your comment, I change the username by the full mail adress. So I replaced : firstname.name by firstname.name@mydomain.com and now it works !

    Thanks a lot for this thread !

    Best regards,

  16. # Outlook 2010 Does Not Work with Windows Server 2003 POP3 Service

    January 19, 2013 1:27 PM
    Hamid Mohseni
    Gravatar
    Thank you Digital Doug
    It's been resolved

Add Comment

Optional, but recommended (especially if you have a Gravatar). Note that your email address will not appear with your comment.
If URL is specified, it will be included as a link with your name.

To prevent spam from being submitted, please select the following fruit: Cherries

Cherries
Apple
Watermelon
Strawberry
Grapes
Pear
 
Please add 8 and 8 and type the answer here: